Frequently asked questions

93-98 Twin Turbo FAQ’s

93-98 Normally Aspirated FAQ’S

15 Responses to Frequently asked questions

  1. Mark Snell says:

    I have a ’93 j-spec with hks exhaust and a hks evc which was on it when I bought it. I was wondering why it can’t be used for bpu? Thanks for the help.

    • admin says:

      I’d head to the “technical” section at SupraForums.com for some feedback.

      BPU is intake, exhaust, DP and boost controller. Not sure why your setup doesn’t qualify.
      Aron

  2. Brian Beezley says:

    Where the heck did you read that you can’t use your EVC as a BC? I can’t find that anywhere….If it’s on this site, that ought to be corrected.

  3. Gigi says:

    Do you sale toy model 1998 Supra MK4’s? If so how much for a plain and for one with twin turbo? Looking for 2 prices in that question. Thank you.

  4. leo says:

    Form witch company is this black supra bodykit?

  5. Surindra says:

    I have supra mk4, I recently change battery and wrongly mismatch the terminal, and the car now not starting up, there is a crank but not starting up. 120a fuse blown I change ready but still not starting up. Please help me what I can do to fix?

  6. Reggie Cook says:

    I have a 93 TT automatic. The manu button is not working and most of the time when I start the car it is in manu mode. Sometimes when I drop the shifter down to L and bring it back up to D it goes off, but not always. Anyone know what the issue could be?

    Thanks
    Reggie

  7. jordan hoffman says:

    hey fellas, I am hunting some info. I have not been able to find engine Dimensions anywhere for a 2jz-gte. any help would be appreciated . looking for intake-exhaust width, oilpan-valve cover height, and bellhousing flange- front of crank pulley.
    thanks in advance
    jordan

  8. Nick says:

    This is a great place to find out everything i need. However there is a lot of text that is cut off by the layout of the site. The “visit us on facebook” and Instagram sidebar covers up a lot of the text in the 93-98 turbo FAQs

  9. Ryan Bennett says:

    I have a ’97 NA Supra and apparently the previous owner had run a wire from the theft deterrent system to the aftermarket radio he installed. This wire is connected to the red and yellow wires (power)running the stereo and if disconnected, the car will not start.

    My issue is that it throws p1300 code (igniter) and after spending $500 bucks to troubleshoot, they can only provide me with what I wrote above. The igniter is not an issue and they actually tested it with a new one. The Supra doesn’t turn over quickly, but does run well.

    That said, does anyone have any thoughts or a solution. I would like to go back to stock and I only uncovered this situation when trying to figure why the sound quality was poor (the RCA jacks were not plugged in correctly).

    The shop said to connect this ‘wire” to the illumination (orange) wire, but that means I have to have the parking lights on to start the car.

    Thanks!

    bennett.ryan31@yahoo.com

  10. Denis Plasse says:

    Hello, I am the happy and unique owner of a Toyota Supra 1995 Turbo 6 speed with roof targa (sorry for my English, I speak English just a little bit). I am looking for a part of my car, the wipers control #84652-14620 which is defective. Could you help me ? Note that I live in Canada. Thank you very much, Denis Plasse (denis.plasse@outlook.com)

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.


Notice: ob_end_flush(): failed to send buffer of zlib output compression (0) in /home/mkivcom/public_html/wp-includes/functions.php on line 4609